Site Logo
Site Logo
 
It is currently Sun Apr 02, 2017 10:16 pm

All times are UTC [ DST ]




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 2 posts ] 
Author Message
 Post subject: Running Macro with Custom Core
PostPosted: Thu Jun 04, 2015 1:51 pm 
Offline
New User
New User

Joined: Tue Jun 02, 2015 10:29 am
Posts: 1
Hi,

I've got a quick question about how to run a macro using Custom Core.

I've tried to run a macro by different ways and the result is not the same depending on the method used :
- old way (Execute( macro ....)) --> works fine
- New way using custom core and using the .RunMacro function --> not the same result, bad result
- New way using custom core + PMMacro. With .Run --> bad result BUT with .RunComplete instead of .Run --> works fine

Why those results are not the same ?

Thanks for help


Top
 Profile  
 
 Post subject: Re: Running Macro with Custom Core
PostPosted: Wed Aug 12, 2015 4:07 pm 
Offline
DELCAM Staff
DELCAM Staff

Joined: Tue Mar 17, 2009 2:30 pm
Posts: 108
Hi, sorry for the slow reply.

Historically we always used to run macros line by line. This allowed us to use substitution tokens and our own variables as the macro ran. However when IF, WHILE, etc were introduced it became necessary to run macros all in one go, otherwise the macro will fail. If you are running a simple macro then you can use any method to run the macro, however if your macro has any complex statements (such as IF) then you must use the RunComplete.


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 2 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB