Site Logo
Site Logo
 
It is currently Sun Apr 02, 2017 6:58 pm

All times are UTC [ DST ]




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 2 posts ] 
Author Message
 Post subject: Can't get my custom component to work
PostPosted: Fri Jun 11, 2010 4:17 pm 
Offline
DELCAM Guru
DELCAM Guru
User avatar

Joined: Fri Oct 08, 2004 8:19 am
Posts: 445
Location: Basildon, Essex, UK
Hi,

I've used the new feature of Moldmaker to add a fully paramatrised user defined component into a cutom catalogue.

I tried and tested the component using the traditional add a component from another model type method. Which worked fine.

Next I added the component to my custom catalogue and setup the dimensions for the other versions of the part.

However when I try to add the component from the catalogue, even if I select the one defined by the original parameters. I get the error message "Failed to import of create the component definition".

Any help would be appreciated.

Thanks,

Jim


Attachments:
HASCO_Encap_Generated_Components.zip [451.2 KiB]
Downloaded 11 times
Capture3.JPG
Capture3.JPG [ 75.31 KiB | Viewed 49 times ]
Capture2.JPG
Capture2.JPG [ 98.67 KiB | Viewed 47 times ]
Capture1.JPG
Capture1.JPG [ 70.35 KiB | Viewed 44 times ]
Capture.JPG
Capture.JPG [ 76.05 KiB | Viewed 44 times ]
Top
 Profile  
 
 Post subject: Re: Can't get my custom component to work
PostPosted: Mon Jun 14, 2010 12:14 pm 
Offline
DELCAM Guru
DELCAM Guru
User avatar

Joined: Fri Oct 08, 2004 8:19 am
Posts: 445
Location: Basildon, Essex, UK
Hi,

I have now managed to get it working. I had to overwrite the library that PowerSHAPE had created in "C:\Users\....\AppData\Roaming\Delcam\Toolmaker\CustomCatalogs\" with the original model.

When I tried loading the library which was created automatically I noticed that there was a problem with the name of the component and also when I tried to correct it and save the model there was a strange error message about layer sizes or something.

I have attached the dodgy library file for you to help with bug fixing.

Regards,

Jim


Attachments:
HASCO - EXTRAS_library_old.zip [428.2 KiB]
Downloaded 9 times
Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 2 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB