Site Logo
Site Logo
 
It is currently Sun Apr 02, 2017 6:53 pm

All times are UTC [ DST ]




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 11 posts ] 
Author Message
 Post subject: PostProcessor 2015 sp1 Problem
PostPosted: Thu Aug 27, 2015 8:26 am 
Offline
DELCAM User
DELCAM User

Joined: Thu Jul 17, 2014 12:23 pm
Posts: 11
Hi.
Delcam PostProcessor 2015 (SP1 CR 6.8.4059 64-bit)

I have a *.cut file, when I make changes to Postprocessor -> re-process cut-file -> undo- > re-process cut-file -> the text in the cut file is not returned to the initial state
and the head angle is not correct


Attachments:
File comment: step1
1.png
1.png [ 108.54 KiB | Viewed 261 times ]
File comment: step2
2.png
2.png [ 9.51 KiB | Viewed 261 times ]
File comment: step3
3.png
3.png [ 9.06 KiB | Viewed 261 times ]
File comment: step4
4.png
4.png [ 30.78 KiB | Viewed 261 times ]
File comment: step5
5.png
5.png [ 10.52 KiB | Viewed 261 times ]
File comment: finish
6.png
6.png [ 142.18 KiB | Viewed 261 times ]

_________________
Live and learn.
Top
 Profile  
 
 Post subject: Re: PostProcessor 2015 sp1 Problem
PostPosted: Wed Sep 16, 2015 8:25 am 
Offline
DELCAM User
DELCAM User

Joined: Thu Jul 17, 2014 12:23 pm
Posts: 11
how to add video here?
it could be useful for understanding the problem

_________________
Live and learn.


Top
 Profile  
 
 Post subject: Re: PostProcessor 2015 sp1 Problem
PostPosted: Fri Dec 04, 2015 12:27 pm 
Offline
DELCAM Guru
DELCAM Guru

Joined: Fri Jan 07, 2005 1:45 pm
Posts: 63
Can you please contact Delcam local office?


Top
 Profile  
 
 Post subject: Re: PostProcessor 2015 sp1 Problem
PostPosted: Fri Dec 04, 2015 2:48 pm 
Offline
DELCAM Guru
DELCAM Guru

Joined: Fri Jan 10, 2014 4:38 pm
Posts: 507
Location: Switzerland
I've installed PostProcessor 2015 sp1, but I don't use it because the new "process as debug" is unable to process larger files than ~100-200 lines.

You should install PostProcessor 2014 R2 and wait for a better version of PostProcessor 2015 : I've had no problem to reopen the files.

_________________
Thank you !

Olivier


Top
 Profile  
 
 Post subject: Re: PostProcessor 2015 sp1 Problem
PostPosted: Fri Jan 29, 2016 1:56 pm 
Offline
DELCAM Guru
DELCAM Guru

Joined: Fri Jan 10, 2014 4:38 pm
Posts: 507
Location: Switzerland
Anyone noticed, that we don't get the same result in 5 axes (head A table B) with PMPost 2015 sp1 (wrong) and PMPost 2014 R2 (correct) ? We made some marks on a part because of this.

I can't understand, that such a bug could pass through the tests !!!

My tip: Don't be too fast to update your PMPost ! If your version is OK, then keep it !

_________________
Thank you !

Olivier


Top
 Profile  
 
 Post subject: Re: PostProcessor 2015 sp1 Problem
PostPosted: Mon Feb 01, 2016 1:25 pm 
Offline
DELCAM Staff
DELCAM Staff

Joined: Thu Sep 30, 2004 12:24 pm
Posts: 103
Location: Birmingham UK
We do test the post-processor quite thoroughly, but there are (literally) tens of thousands of option files and we can't test every one - partly because we don't have every one.

Have you reported your problem to your Sales Partner? If not, please do so, including:
- the option file
- the cutfile or the PowerMILL project with details of which toolpath shows the problem
- what you believe is the correct G-code
- what you believe is the wrong G-code

If you have reported it, let me know what the reference is and I can see how it is being addressed.


Top
 Profile  
 
 Post subject: Re: PostProcessor 2015 sp1 Problem
PostPosted: Mon Feb 01, 2016 5:44 pm 
Offline
DELCAM Guru
DELCAM Guru

Joined: Fri Jan 10, 2014 4:38 pm
Posts: 507
Location: Switzerland
Sorry, not yet, but I'll do it as soon as I get a some time to do it.

By the way, I never received the reference # whenI submit a problem.

_________________
Thank you !

Olivier


Top
 Profile  
 
 Post subject: Re: PostProcessor 2015 sp1 Problem
PostPosted: Mon Feb 01, 2016 6:52 pm 
Offline
DELCAM Staff
DELCAM Staff

Joined: Thu Sep 30, 2004 12:24 pm
Posts: 103
Location: Birmingham UK
If your SP has reported it to us then there will be a reference number from the International Support team. Ask your SP.


Top
 Profile  
 
 Post subject: Re: PostProcessor 2015 sp1 Problem
PostPosted: Wed Jun 22, 2016 2:17 pm 
Offline
DELCAM User
DELCAM User

Joined: Thu Dec 22, 2011 1:52 pm
Posts: 20
I'm unable to debug even a very short powermill .cut file with 2015 SP1.
2014 works just fine. But I would like very much to be able to use the other improvements in 2015 SP1.

It there any word on just how short does the .cut file need to be for the debug to succeed?
Or is it the output of the postprocessor that needs to be short enough?


Top
 Profile  
 
 Post subject: Re: PostProcessor 2015 sp1 Problem
PostPosted: Wed Jun 22, 2016 3:17 pm 
Offline
DELCAM Guru
DELCAM Guru

Joined: Fri Jan 10, 2014 4:38 pm
Posts: 507
Location: Switzerland
If you have a look at my previous posts: Just forget PostProcessor 2015 sp1, go back to PostProcessor 2014 and wait for the next update.

I was just unable to debug more than a small sample file and experienced a big bug in the 5 axis moves.

PostProcessor 2015 sp1 is definetly not ready for "serious" use.

_________________
Thank you !

Olivier


Top
 Profile  
 
 Post subject: Re: PostProcessor 2015 sp1 Problem
PostPosted: Wed Jun 22, 2016 3:44 pm 
Offline
DELCAM User
DELCAM User

Joined: Thu Dec 22, 2011 1:52 pm
Posts: 20
Yeah, I can't get the 2015 SP1 version to debug anything.
I managed to create a 35 row postprocessor output (including 16 lines of comments). But still no luck. Don't really know how much shorter programs will still be beneficial to debug at all.

Guess I'll be forced to move down to 2014 R2 SP1. Bummer.

2015 SP1 is close to a year old! You would think that one of the nice new features, "reworked debug" would have been fixed by now? Support of course can't help at all.


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 11 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB